Minimum operating system requirements (Windows PC)

To run the Windows PC version of Paltalk we recommend Windows 7 or above.

Some users have reported success running Paltalk on Windows XP SP3 and Vista, but we do not officially support it below Windows 7.

Did this answer your question?