Operating system requirements (Mac)

To use the Paltalk app you must have OSX version 10.9 or above.

Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.