Operating system requirements (PC)

Minimum operating system requirements (Windows PC)

To run the 'new generation' PC version of Paltalk we recommend Windows 7 or above.

Some users have reported success running this new version on windows XP SP3 and Vista, but we do not officially support it on operating systems below Windows 7.

 

Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.